I am trying to upgrade from 1.5 to 1.7 and am having no luck.

I backed up my database, and all the wikimedia files.

I have tried entering RAW commands using my FTP program to no avail. Why is it not possible to run this update script from the godfather-role?

updating mediawiki-2

PP: Question does sanyone know where to find the official Mediawiki documentation regarding this subject The problem I've been having with this same upgrade is that files use php4 by default on Godaddy.

I've been told that to use PHP5 the files extentions need to be changed to .php5.

For them, here is a list of simple steps to Now Download latest Media Wiki package from Make sure your server environment supports the version of Media Wiki that you are planning to install. If your server does not support, you should first ask your host to upgrade server to required PHP and mysql versions.

Upload the new Media Wiki package on your server using an FTP client (like File Zilla).

--Wolf530 , 14 January 2006 (UTC)The point is not that it is free as in "free to the user" but free as in "developer's don't get paid".

The software is primarily written to manage the Wikimedia projects, but having developed the software for that purpose it has also been made available to anyone else who wants to run a wiki.

Check Special: Version page to see if it is showing the latest Media Wiki version.

Also try editing a page and upload a file to see if all is going on as it should.

The developers listen to and actively help out users, if you use the appropriate channels of communication.